Welcome to the new Customer Portal! We are still in the process of moving all our customers so please bear with us if you are temporarily unable to log in. You can still email [email protected]!

Mac and iDevice sign in issues

This problem is not new but it is starting to have am impact on my business. The bottom line is Safari users seem to have issues logging in. It seems that Mac users who use a Chrome browser do not have an issue. iPad users seem to have a lot of issues.

I wonder if the fact that my forum is embedded in an iFrame makes a difference / makes it unique? I personally do not own any Apple devices but a lot of my users do. About 40% percent of my users are on Apple report some sort of issue signing in. It seems like they can log in for a while and then one day they can not.

From a support perspective I know you (Vanilla Support) want/need a narrative to reproduce the problem. I do not have one. It seems that when these users log in they enter the right password but then nothing happens. When I look up their account it appears they were logged in. So they are logged in but not redirected to the page where they can act as a logged in member. Something like that.

Please see comments from my users. http://www.ballofspray.com/forum#/discussion/12214/site-software-question-please-answer-this-poll/p1

Here is a poll I ran.
image

I tell all users with a Mobile Apple issues to do the following. Sometime it helps and sometimes not.
Apple mobile devices login trouble shoot guide. iPhone, iPad & iPod

Apple mobile devices login troubleshoot guide.
1. Completely close Safari by double clicking the home button twice quickly then swipe up on the Safari App.
2. Shut off you device completely then reboot.
3. Go to Settings->Safari->Block Cookies->From third parties and advertisers (you can also click never)
4. Launch Safari then go to the mobile forum. Sign in with your username and password. Click "Done" on the keyboard and make sure "Keep me signed in" then click "Sign In"

Comments

  • LauraLaura Support, Staff

    Horton,

    The issue is likely due to the embed. If you could, do a followup specifically for the users having an Apple login problem. You'll want OSX version, browser & version, and whether they all experience the same thing: a login that just does nothing and has no error.

    With that information I maybe able to isolate the issue and perhaps the devs can pass along some advice for fixing it.

  • Below are comments I have gotten from my users

    The most common issue I get on my iPhone is if "back" out of a thread to the main forum page it will look like I logged out. Refresh or "forward" shows I'm still logged in. Also if I hit the "home" from a thread I get no issues.
    On the iPhone 5 (iOS 8.1.1) I have to log in every time I visit the site. I also have the issue of (appear) to be logged out if I hit the back button. Clicking on "Home" again logs back in so I don't think its really logged out. That said if I close or move off of safari I will need to log back in again. On the iPad Mini using Safari and iOS 8.1,2 I cannot log in at all. The log in and password is not recognized.

    iOS 8.1.1 on iPhone 6 using the Safari browser. No problem signing in, but after shutting down the browser and restarting, my login is gone and I have to sign in again.

    No problems ever on my iMac OS X 10.9.5, using Safari Version 7.1
    No longer any issues w/my iPhone 6 (iOs 8.1.1), a welcome relief from previously having to log in every time accessing BOS on this phone as well as iPhone 5 and 4.

    On my initial visit to http://www.ballofspray.com/forum the site seems to pick up my cookie and recognize me. If I read a thread, then click the back button I get an outdated thread list and the sidebar of the site indicates that I'm not signed in. If I refresh the page, it seems to pick up my cookie again, show me the latest threads, and recognize me as a user. This is with Chrome on the past 3 versions of OSX. This does not happen on my home Mac which is nearly identical to this one so that further complicates things. I've cleared cache/cookies in the past but the problem persists. Is there a way to have the forums page load the threads in a non-Ajax manner, doing it all server-side? If that's an option it might make the experience more consistent.

    On an iPad air iOS 8.1.1 with safari I cannot log in with my BOS name and password. With my iPhone6 iOS 8.1.1, I can log in with standard BOS user name and password

    I have issues signing in with my iPad 2 on OS Version 8.1.1 using Safari. Original iPad on older OS version worked perfectly

    iPad 4th Gen, 32 GB, Wi-Fi, MD511LL/A IOS 7.1.2 sometimes won't sign in. It's working right now though.
    My Macbook pro has no issue BUT... my iPhone 5c and iPad air can view the site but will not let me sign in to comment.

    i almost always log on from my mac's (imac and macbookpro, OSX, with chrome)
    It will "recognize" me most of the time, and log me automatically, but eventually (even thaugh i never clear cookies or cache or whatever) it will not recognize me. (sometimes, 5 minutes after I was on the site, on that same computer, same session, no restart, no nothing, simply closing the browser and reopening it)

  • edited December 2014

    I regularly hear from readers that they cannot sign in with one Apple device or another. I understand that it could be user error but I to not ever hear any issues from PC users.

    Please advise.

  • This issue seems to be the same as this old issue
    http://vanillaforums.com/discussion/comment/10318/#Comment_10318

    @Lincoln Do you have notes from last year?

  • Hey Horton! I can't even remember what happened last week. :( I'm sure the support team will start digging into this tomorrow.

  • LauraLaura Support, Staff

    Horton,

    It may seem ridiculous... but I need you to confirm that none of the safari users are in private browsing mode, because after the update some users did not realize there was a difference between the two. In safari if they have a dark grey interface they are browsing privately. We had some troubleshooting with mac issues on another forum, and it turned out all the users with issues were in private mode.

    This does not account for the issues with chrome, but I still need to narrow things down a bit more before we can look into anything.

    Thanks.

  • I asked around and the answer is no.

  • LauraLaura Support, Staff

    Okay, Horton,

    We will do some testing and try and reproduce things with some consistency. I'll let you know what we encounter.

  • LauraLaura Support, Staff

    Hey Horton!

    Hope the Holidays treated you well. I have a request from the developers that I need you to complete so we can see if it effects your issues: Use the Custom Domain page to assign a subdomain such as forum.ballofspray.com to your forum, then to get new embed code from the Dashboard (that uses the subdomain) to re-implement.

    See if this alleviates anything, then report back with the results. Let me know if you have any questions.

    -Laura

  • Hey Laura,

    The sub-domain ballervf.ballofspray.com has been created and and entered into the Dashboard => /settings/customdomain page.

    The URL works so I think I got it right. Let me know if I missed anything.

  • LauraLaura Support, Staff

    The URL looks good. Did you update your embed code as well?

  • nope i missed that step. It is done now.

  • LauraLaura Support, Staff

    Cool. Give it a few days and instruct users to clear their cache if they are still having issues. Let me know what happens.

  • So when say give it a few days => you think it might be fixed and you want me to get my users to cycle through or... the real change will be made in a few days?

  • The former, thankfully!

  • @Patrick & @Laura

    It looks like the issue is solved. Apple loving water skiers around the world thank you.

    One question. When I created the CName and then updated the embed code was there any action required at your end? I was not really thinking very clearly when I created the CName and would like re-do it with a better URL.

  • LauraLaura Support, Staff

    Nothing was done on our end, you just need to do it in that particular order. First fix the custom domain, then redo the embed.

    Glad the issue is resolved, Thanks for hanging with us as we isolated it!

This discussion has been closed.